Coffee Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
Just wondering if anyone could offer some advice on my K30.

I've had this for about 4 years (bought used) and replaced the burrs when I first got it. Its worked fine all the time that I've had it and Its only used a few times a week. Recently, however, I've found that I needed to adjust the grind a bit coarser than usual as the grinder would occasionally jam. I've stripped it down and cleaned everything and the burrs still look ok but, when I try to grind, I can still not get the coffee as fine as I need it to be for my Londinium. I've tried setting the burrs so they are touching and then backing them off just a little, but the grind is still not fine enough and it jams if I try to adjust it finer.

I'm reluctant to fork out for another set of burrs as I don't think they are the problem but I'm at a loss as to what else it could be.

Any advice/suggestions would be greatly appreciated.

Thanks
Graham
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #3 ·
Thanks for the suggestion.

On reflection, and having had a good look at some newer grinders, I'm coming round to think that I might just sell it for spares/repair and get something newer, rather than spending money on an old machine.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #6 ·
Thanks for the advice. I'll look into the possibility of it being the capacitor as that would make sense. Pretty certain that its not the burrs as I've worked out that I've only ground about 80kg of beans since I replaced the burrs and carrier. I'll try to source a new capacitor and update once I've tried it.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #7 ·
Replacement capacitor arrived today and the grinder is now working as it should! Thanks to El carrajillo for the suggestion that this could be the problem! Now I just have to decide whether to keep the K30 or the Super Jolly Electronic that I bought as a temporary 'stop-gap'. Or whether to sell them both and look out for a Lagom P64 which looks like a better long-term bet than the HG1 that I was thinking of getting.

Decisions, decisions.... And to think that, before I started having problems with the K30, I was quite happy with what I had! Looks like the bug is biting again!
 

·
Super Supporter
Joined
·
6,137 Posts
Replacement capacitor arrived today and the grinder is now working as it should! Thanks to El carrajillo for the suggestion that this could be the problem! Now I just have to decide whether to keep the K30 or the Super Jolly Electronic that I bought as a temporary 'stop-gap'. Or whether to sell them both and look out for a Lagom P64 which looks like a better long-term bet than the HG1 that I was thinking of getting.

Decisions, decisions.... And to think that, before I started having problems with the K30, I was quite happy with what I had! Looks like the bug is biting again!
Glad it sorted it out, take care with the 'bug' biting it devours cash and credit cards faster than you can feed it😂
 
1 - 8 of 8 Posts
Top