Coffee Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 6 Results
  1. Gaggia Forum
    Not sure what I have done wrong. I installed a C100 PIDand thought I followed all instructions but heating continued past the alarms. I then took the PID out and the problemremains. Checking the wiring it seems fine (compared to photos onhere) but obviously isn't. I left the PID powered and...
  2. Gaggia Forum
    Looking for some assistance. Got up this morning and machine was cold, set to come on 30 mins prior. PID was reading 0.00 temp, both lights were on. I thought i smelled a slight burning smell yesterday. I opened it up and there is no obvious problems. PID is from Mr Shades. I'm looking on...
  3. Coffee Accessories
    Just wondered what experience anybody has had trying to prevent their coffee van from freezing up overnight? We aren't able to 'garage' our vehicle, so need to rely on some form of heating on the colder nights. We can get a mains supply into the vehicle overnight, so battery usage isn't a...
  4. Coffee Business Owner Support Forum
    Hi All, I'm after some advice. I work in a large shop in a tourist town that sells vintage/retro/industrial furniture. We have a cafe that originally sold coffee/tea and cake and had one member of staff. Then after many people asking if we sold lunches we jumped in - invested in a small...
  5. Fracino Forum
    Hi everyone, I recently helped a friend of mine set up the first coffee shop in Liberia, West Africa. In September last year I brought out a new Fracino Little Gem (needed to be hand fill, use a normal power supply, low frequency etc). Unfortunately, it has stopped working, and being in...
1-5 of 6 Results
Top