Coffee Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 6 Results
  1. Sage Forum
    i have had other semi automatic/automatic machines mainly delonghi and making an espresso they were at least warm (ish) on a barista touch i have, when making an espresso it seems to be almost cold and mildly warm. is this normal? my cups are not pre-heated/warm water or anything/ but i didn't...
  2. Brewed Coffee
    Hi everyone, its great to join your community. I have recently designed a product that turns your Aeropress into a Kyoto drip tower. Its a small addition to your Aeropress that radically changes the way it brews allowing you to make a 2.5 hr brew through the system whilst still using the...
  3. Gaggia Forum
    Hi - just wondered if anyone could give some advice. I am using a Select Deluxe (almost a classic) I prime the pump and wait 10 mins - however (especially with latte) I get complaints about the coffee being 'tepid'. I often have to give a 10 second microwave blast to keep the wife happy ;-)...
  4. Technical | Faults | How-to's
    Hi there I have a Gaggia Espresso Color which was ex display from a Gaggia shop and it leaks water as it is pouring coffee through the double spout at the base of the filter holder. The water is leaking between the thread and the spout part, so I don't think it's a group heard gasket problem. I...
  5. Technical | Faults | How-to's
    Hello, Hoping someone can help. I have a Kenwood espresso machine which was stopped heating the water. It still makes steam however, and otherwise appears to be operating normally. Pump still works, but cold espresso is created. I know some might say [myself included] buy a new/better...
1-5 of 6 Results
Top